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FileMaker Pro Scripts and Buttons

You can use scripts to automate multiple step processes. If you have ever heard the term macro,
a script works the same way. You can use buttons to easily access a script you create.

Create Single Task Buttons

1. New Record Button
a. Choose a layout where you would like the button to appear.
b. From the View menu, choose Layout Mode.

c. Click on the Insert Button icon (see below).
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d. Move your mouse into a blank area of the layout and your pointer will become a plus
sign. Click, hold, and drag in a diagonal direction to create a button.
e. Since you have yet to create a script, you can only choose one item from the Specify
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Specify Button,

Bressa-ar-Fd mode, clicking on
the selected set of objects will:

Insert from Last Record A~
Insert Cunent Date b |
Insert Curent Time
Insert Current User Mame
Ingert Picture
Insert Quick Time
Insert Dbject
Update Link I
Records t = Button Syle

e sl &

Duplicate Record/Request & Rectangular buttan
Delete Fiecord/Request Bt bultar
Delete Portal Row
Revert Record/Request

Evit Record/Request IV Change to hand cursor over buttan
Copy Recard

Copy All Hecords

Delete Al Records v Cancel

f. Scroll down to the Records category and click on New Record/Request. You can
change the button style and/or you can change the cursor to appear as a hand when
you move the mouse on the button. Click OK.

g. There is now a cursor blinking in the button you created. Type in a name for the button.
Click outside of the button.
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h. From the View menu, choose Browse Mode and try out your new button.
2. Delete Record Button
a. Complete the same steps you did above, except, choose Delete Record/Request in
the Specify Button window. With this command, you have one additional option:
Perform without dialog, i.e. do you want to get a warning before you delete a record? If
you do, leave the box unchecked.
b. From the View menu, choose Browse Mode. You now have two buttons: Add Record
and Delete Record.
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3. Other Single Task Buttons
Any bold item listed in the Specify Button window can be a single task button. When you

need to put multiple steps together,

S pecify Button

In Browse or Find mode, clicking on
the selected set of objects will:
-~

Control

Perform Script

Fiezume Script

Exit Script

Halt S cript

Mavigalion
Go to Lapout
Go to Record/Request/Page
G to Related Record
Go to Portal Row
G to Field
Go to Mest Field
Go to Previous Field
Erter Browse Mode
Enter Find Mode
Erter Preview Mode
Sort/Find/Print
Sort
Unsart
Show All Records
Show Omitted
Ornit Record
Omit b ultiple
Perform Find
todify Last Find
Frint Setup
Frint v

Optiohs

Button Style

{+ Rectangular buttan
" Rounded button

o |

Cancel

ou will first have to create a script.

Specify Button

In Browsze or Find mode, clicking on
the selected zet of objects will

Editing ~
Unda
Cut
Copy
Paste
Clear
Select Al

Fields

Insart from Index

Insart from Last Record
Insart Current Date
Insart Current Time
Insert Current Ulser Name
Insert Pictue

Insert QuickTime

Update Link.

Records
Mew Record/Reguest
Duplicate Record/Request
Delete Recod/Reguest
Drelete Portal Row
Fevert Record/Regquest
Exit Record/Regquest
Copy Record
Copy All Records
Delete &ll Records
Feplace Contents
Relookup Contents
Import Records
Export Records -
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Options

Button Style

' Rectangular buttan
" Rounded button

o]

Cancel

Specify Buiton

In Browse ar Find mode, clicking on
the selected set of ohjects will

Windows A~
Freezs Window
Refresh Window
Scroll window
Toggle Window
Toggle Status Area
Toggle Text Ruler
Set Zoom Level
View Az
Files
New
Open
Cloze
Change Password
Set Multi-User
Set Use Spstem Formats
Save a Copy as
Fiecover
Spelling
Check Selection
Check Record
Check Found 5et
Correct Word
Speling Options
Select Dictionaries
Edit Uzer Dictionany
Open Menu ltem
Open Application Preferences
Open Document Preferences
Open Define Field:
Open Define Relationships
Open Define Walue Listz
Open Find/Replace
Open Help
Open Hosts
Open Scripthd aker
Open Sharing v

Options

Button Style

" Rectangular buttan
" Rounded button

o]

Cancel

I Browse or Find mode, clicking on
the selected set of objects will

Open Hoslz ~
Open Scrpthd aker
Open Shaiing

Miscellaneous

Allowy Toolbars
Beep

Flush Cache to Disk
Exxit &pplication A

Options

Buttan Style

+ Rectangular button
" Rounded button

Specify Button

NOTE: When printing layouts that contain buttons, the following must be done in order for the

buttons not to appear on the print outs:

abrwNPER

Select the layout where you have the button.

From the View menu, select Layout mode
Click once on the button to select it.

From the Format menu, select Sliding/Printing...
Check the box next to Do not print the selected objects.
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Create a Script
1. Plan! Before you begin the process of creating a script, try to map out as best you can
what you want to accomplish with the script or scripts.
2. If your script includes an import, export, find, sort or print setup, you must specify the
settings before adding such a step to a script.
3.

Common Scripts
1. Print a Letter

a. From the File menu, select Print Setup...
b. Select the appropriate paper size and orientation for your letter and click OK.
c. Choose the layout containing the fields you will use to select a subset of your data.
d. From the View menu, select Browse Mode.
e. From the Records menu, select Sort... Choose how you want to sort the file. Click
Done. You do not need to actually sort the file.
f. From the View menu, select Find Mode.
g. Create the find request(s) to select the records. You do not have to click on Find.
h. From the Scripts menu, select Scriptmaker...
i. Name your script and click on Create.
Define Scripts for, “F& Update File Training Orig.fp5" E]@
[ oo
Frint...
Import...
_Ferere_|
_ Dules |
[ o
Script Name W Include in menu
|Prirt Letter Done

j. One by one, you will add the steps that, when executed together, will resulted in a
printed letter(s).

Script Definition for “Print Letter™

Wiew | all by categon = "Prirt Letter
Control ~
Peiform Script
Pause/Resume Script
Exit Script
Halt Script
If
Else
EndIf
Loop
Exit Loop IF
End Loop
Allow Uzer Ahort
Set Ermor Capture
Go to Aelated Record ¢ 2
oto Related Recaon
Gioto Portal Row Dptians
Goto Field
G to Next Field
Go to Previous Field

b

k. Click on Go to Layout and then click on Move.
I.  Each script step will involve making certain selections under the options area.
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Script Definition for "Print Letter”

View all by category -

Control ~
Perform Sciipt
Pauze/Resume Script
Exit Script
Halt 5 cript
If

Else

EndIf

Loop

Exit Loop IF

End Loop

Allow User sbort

Set Ermor Caphure
Havigalion

Go o Lapout

Go to Record/Request/Fage

Go to Related Recard

Go to Portal Row

Go to Field

G to Mest Field

Go to Previous Field ™

Coarl | Cloar |

“'Print Letter*

# Goto Layout [Rel

< >
Options
¥ Fefresh windove

Cancel

Duplicate |

m. In this step, it is necessary to specify the layout you want to use.
Howdy Letter. The Refresh window option will cause the layout view to immediately
change to the chosen layout view instead of waiting until the script has completely

executed.
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In this case, it is the

n. Under the Sort/Find/Print category, select Show All Records and click on Move.

©

Under the Sort/Find/Print category, select Sort and click on Move.

p. Scroll down to the Sort/Find/Print category and select Perform Find. Click on Move.
To use the Find request created when the script was created, make sure there is a check
mark in the Restore find requests box.

NOTE: At any time, you can hit the F1 key to bring up the Help Menu for creating scripts.

You can search for your script step either by category or alphabetically. All of the options

for the script are explained.

g. Under the Sort/Find/Print category, select Print Setup and click on Move.
r. Under the Sort/Find/Print category, select Print and click on Move. By default, this

is NOT done without a dialog box.
s. Click on OK.

t. Click on Done. Your script is complete.

Script Definition for, "Print Letter™

Wiew all by categony -

“Print Letter”

Go to Previous Field -
Erter Browse Mode
Enter Find Mode
Erter Preview Mode

5 ort/Find/Print
Sort
Unzart
Show All Records
Show Omitted
Omit Record
Ot Multiple
Perforn Find
Modify Last Find
Frint Setup
Pririt

Editing
Unda
Cut
Copy
Paste
Clear b’

Clearél | Cea |

# [Goto Layout [Refiesh window, "Howdy Letter']
# Show All Records

# Sort [Restore, Mo dialog]

# Perform Find [Restare, Replace Found Set]

% Prirt Setup [Restore, Mo dislog)

% Prirt ]

4 ¥
Options

[ Perform without dialog

Cancel

Duplicate |

u. Run the script by selecting it from the Script menu or create a button to perform the

script.
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2. Print an Envelope
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a. You are going to follow the same steps for printing a letter, with two exceptions:
i. You need to save new settings in the Print Setup box.

Print Setup Elgl
Frinter
MName: Froperties..
Status; Ready
Type: HF Laseret 5000 Seres PCL
Where:  Common work area near server room
Comment: TS 3rd Floor
Paper Qrientation
Size: @ j " Porbrait
Source: |Aulumalical\y Select j
Network... Cancel
ii. You need to select the Envelope layout when adding the Go to Layout step in the

script.
3. Send an E-mail

Specify Field

+ Uze all records in found set

It can either come from fields in your database or

21X

| Current File ["Fr Scripts and Buttons classﬂ

Last Mame ~
First M arme
Birthdate
Address
Address2

City

State

Zip

b ajor
Favarite Colar
Pet's Mame

Repetiion |1

Records

Define Fields. ..

" Uze curent record

]

Cancel |

a. Make the desired sort and find requests.
b. From the Script menu, select ScriptMaker...
c. Name the script and click on Create.
d. Scroll down to the Sort/Find/Print category and select Perform Find. Click on Move.
e. Scroll down to the Miscellaneous category and select Send Mail.
f. Click on Move.
g. Click on Specify.
h. Fill in the appropriate information.
you can type the text in the box. NOTE: When you specify a field, you have the option
of using all records in the found set.
Specify Mail [ZIR) { specity wail B
To Tor
" Field Value @ FieldValue  Speciy.. | "Email address”
& Tedt | Address. . © Test |
CC: CC:
" Field Y alue  Field Value
& Tent | Address.. & Test | Address..
Subject: Subject:
O FeldVae ool | O Fiskdvaue el |
& Test | @ Test [ou wonthe oteen!
Message: Message:
" Field Y alue  Field Value
&+ Text & Text |l am happy to inform you that you just won the lotterd You A
may pick up your winnings at the ITS Help Desk. Ask for
['ana and she will be happy to assist youl v
[ Attach File [ Attach File
Cancel Cancel

Click on OK.

Click on OK to close the Script Definition window.

i

j.

k. Click on Done.
|

To execute the script, you can select it from the Script menu or create a button. The
default e-mail program installed on your computer will automatically open a new
message window. Click Send.
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Edit a Script
When you create a script, you save the print setup, import, find, sort, or export settings with the
script. As you change these settings and edit your scripts, the following window will appear. If you

FileMaker Pro

The follawing information is needed ta perform this
sCript. r'ou can;

* Keep the information already saved for this script
* Replace it with the infarmation curently in use

Pririt 5 stup: @ Feep  Replace
Import Order. i i
Find Requests: ™ Keep 1 Replace
Sort Order: * Keep  Replace
Export Order: i i

Cancel

Create a Button to Execute a Script

a.
b.

f.

Choose a layout where you would like the button to appear.
From the View menu, choose Layout Mode.

Click on the Insert Button icon

Move your mouse into a blank area of the layout and your pointer will become a plus

sign. Click, hold, and drag in a diagonal direction to create a button.

In the Specify Button window that appears, click on Perform Script. Under options,

specify the script you want to run. Click OK.
™ FileMaker Pre

Fiun Lett...v|
=

Specify Button

In Browse or Find mode, clicking on

1~ Dptions-

: i — | speoiy -
Body } # 5 —— R
r Halt Script FPause - 1 current scipt | T

Footer

Buttan Style-

+ Rectangular button
" Rounded button

Mavigation
Go to Layout

Go to Record/Request/Page
Go to Related Record » Ok | Cancel ‘

¥ Change to hand cursor over button

There is now a cursor blinking in the button you created. Type in a name for the button.
Click outside of the button.

For questions or comments regarding this document, please e-mail docxteam@hamilton.edu.
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