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Excel Macros

What is a Macro?
A macro is a series of instructions that you perform with a single keystroke or click of the mouse.
If you perform repetitious or complex tasks, a macro can automate the process.

Planning a Macro

Among the many tasks you can record in a macro are each menu and cell selection, formula
creation, and column and row insertions. The recording is done in the exact sequence in which you
perform the steps. Although it is possible to edit a macro, it is much easier for a beginner macro
user to plan a macro before recording it.

Creating a New Macro
1. From the Tools menu, select Macro, and Record New Macro... The Record Macro
window will appear.

Macro name:
ICaIcuIation
Shortout key: Skore macro in:
Ctrl+|t_ INew ‘Workbook j

Description:

Calculates the MIN, MAX, AVERAGE, and SUM|of range
named enrollment

Ok | Cancel |

2. Give your macro a descriptive name. The first character of a macro name must be a letter.
Other characters can be letters, numbers or underscore characters. If you attempt to use
spaces, dashes (hyphens) or other special characters in your macro name, you will get an
error message.

B

A That name is not valid.

3. Assign a shortcut key to the macro (optional). Click in the box to the right of Ctrl + and
type a letter. The shortcut key is case sensitive. If you want to use an uppercase letter,
hit SHIFT and the letter. You cannot use numbers or special characters. If you do not
want to use a shortcut key, leave the box blank.

NOTE: Some keys are already assigned to perform other actions within Excel, e.g. CTRL+c =
copy, CTRL+x = paste. Here are a few keys that, by default, are not assigned: (Win: CTRL+e,
CTRL+j, CTRL+m, CTRL+t. Mac: OPTION+CMD+a, OPTION+CMD+b, OPTION+CMD+-c.

4. Click the down arrow under Store macro in: to select a location to store the macro. This
Workbook - will attach this macro to the current workbook, and it will only be accessible
when this workbook is open.

Personal Macro Workbook — will make the macro available from any Excel workbook you
open on the computer. The first time you save a macro to Personal Macro Workbook also
called personal.xls, you will see the following window when you quit from Excel.

x|

Do you want to save the changes you made to the Personal Macro Warkboaok? If vou click Yes, the macras will be
. available the next time you start Microsoft Excel,

Yes Yes To All | Mo | Cancel |

New Workbook — will attach the macro to a new workbook file (will not contain any data,
only the macro). Use this option if you need to share the macro with another person or
need to use it on more than one computer.

5. To begin recording your macro, Click on OK in the Record Macro window.
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Recording a Macro

1.

4.
5.

When the Record Macro window closes, you will see your spreadsheet with a small Macro
Recording toolbar floating off to the side. You can move the toolbar without affecting the
macro. There are two buttons on the toolbar, Stop and Use Relative Reference.

n
If you click the X to close this toolbar, Excel will stop recording the macro. You can also
stop recording by clicking Stop.
The Use Relative Reference button determines whether the macro recorder uses relative
or absolute references to the cells on a worksheet. By default, the button is set to
Absolute. This means that the macro will select the same cells regardless of the position of
the active cell when you run the macro. If you click on the Use Relative Reference
button, Excel will record the macro relative to where you start (e.g. if you want to insert a
row or column at the active cell. You can switch between modes while recording your
macro.
Next, select, format, create formulas, etc. that you want to be contained in the macro.
Click on the Stop icon on the Macro Recording toolbar.

Running a Macro

1.

From the Tools menu, select Macro and then Macros.... If the macro is contained in
another workbook, open that workbook before attempting to run the macro.

2. Choose the macro from the list under Macro name: and click on Run.

Mocro 2(x|

[Macro name:

o
(=
3

-

Cancel

Step Inta

Edif:

Create

LI Delete

Macros in: All Open Workbooks j Options. ..

[ LKl

Descripkion

If after you save a workbook that contains a macro and try, unsuccessfully, at a later date

to run it, you may need to change the security settings within Excel. From the Tools

menu, select Macro and then Security. (Mac: From the Excel menu, choose Preferences

and then click on the General tab. Select the Macro virus protection check box.)
Click on Medium and then click on OK.

[ x|
Tools | Data ‘Window Help  Acrobat =
. - H | Trusted Sources I
5|V apeling... F7o (a8l i ) - Al - 10
. - ¢~ High, Gnly signed macros From trusted sources will be allowed
45 Error Checking. .. to rup, Lnsigred Siealdicabled.
Share Workbook, .. & Medium, You can choose whether or not to run pobentially
safe macros.,
I Pratection 3 [ G [ H [ [
¢ Low {not recommended), You are nok prokected From
Online Collaboration » patentially unsafe macros. Use this setting only if vou have
virus scanning software installed, or you are sure all
Formula Auditing 3 documents you open are safe,

Tools on the Web. ..

Macra 4 | p [Macros,.. Ale+Fa
Cuskaomize. .. @ FRecord New Macro...
Options. .. | Security. .,
¥
¥
E idalEa=lediog Pl Yirus scanner(s) installad,
&8 Microsoft Script Edikor — Alk+Shift+F11 P
= -OK Cancel
S ——
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Editing/Deleting a Macro

In order to edit a macro, you need to edit the actual visual basic code.
1. From the Tools menu, select Macro and then Macros....
2. Select a macro from the list and then click on Edit or Delete.

aco TN

Macra narme:

Unhide workbook:

<
Macros in: IF'.ll Qpen workbooks j

Description

Macro recorded 10/4/2002 by username_wzk

NOTE: If you have saved your macro in the PERSONAL.XLS as the macro show above was, then
you will not be able to edit or delete the macro yet, you will have to unhide the personal workbook.
From the Window menu, select Unhide. Click on PERSONAL.XLS and then click on OK. This
worksheet should be hidden again when you are done editing or deleting macros in it. When you
are in the PERSONAL.XLS worksheet, from the Window menu, select Hide.

gl Microsolt Yisual Basic - Enrollment Macro.zls - [Modulel {Code)] - | [m] 1'
% Eile Edit View Insert Format Debug Run  Tools  Add-Ins  Window Help Type aguestionforhelp = 2 A x
MiaE-bdd2ad oo ) 0 s &HEE? 0 nol .
Properties - Modulel [X] I(General) j ICaI':uIa'(ion j
[Module1 mModule =1 —
b Sub Calculationf() o
alphabetic | categorized | \ =
HIMMUdulal ' Caloulation Macro
' Macro recorded 3/23/2004 by Maureen Scoones Calculates the MIN, MAX, AVERAGE, and 3UM of range
! FKevhoard Shortcut: Ctrl+t
'
Windows ("Spring 04 Training.x1s"™).Lotivate
Range ["E1"™) .Z3elect
AetiveCell.FormulaR1C1 = "STATS™
Range ["EZ2") .Z3elect
AetiveCell.FormulaR1C1 = "HIN™
Range ["F2™) .Select
AetiveCell.FormulaR1C1l = "=HIN(enrollment) ™
Range [("E3"™) .Select
LetiveCell.FormulaR1C1 = "HAX"
Range [("F3™) .Select
AetiveCell.FormulaR1C1l = "=MiX(enrollment) ™
Range ["E4"™) .Select
AotiveCell.FormulaR1C1 = "AVERAGE"
Range ["F4™) .S3elect
AetiveCell.ForwulaR1C1l = "=AVERAGE (enrollment) ™
Range ("ES™) .Select
Aerivecell.FormulaR1C1l = "SUM”
Range ("F5") .Select
AetiveCell.ForwulaR1Cl = "=53UMienrollment) ™
Range ["E&"™) .Z3elect
End Sub
= KT I— e
ii‘Startl e ZIP-100 {E:) | |53 Hamiltan I Ex:e\ Macras - Mi... | @Excel Macros Exa... | Mi:rusuft Excel- ... | al“licrnsuft Yisual.. My Documents > | < B8] 11:44 PM
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Assigning a Macro to a Toolbar

1. Create a Toolbar.
a. From the Tools menu, select Customize.
b. To add a toolbar, click on the Toolbars tab and then click on the New button.

Customize R
Commands I Options I
Toolbars:

Drawing
[ Exit Design Mode

[ External Data Reriamz. ..
[ Farms |
[ Full Screen

Delet
[ Picture Delste |
[ PivotTable
[ Refresh Resat... |
[ Reviewing
[ Shadow Settings Attach, .. |
[ Stop Recording
[ wisual Basic
[ web

[ wordart
¥ workshest Menu Bar ;I

1) Cose |

c. In the New Toolbar window that appears, enter a name for your custom toolbar.

Toolbar name:
—
Cancel |
d. Click on OK.

e. A very small box will appear that represents your new toolbar.

=
2. Add Buttons to the Toolbar.

a. In the Customize window, click on the Commands tab.
b. Under Categories, click on Macros. )
| Customize 2lx

|My Macros|

Toolpars ~ Commands I Options |

| Toadd acommand to a toolbar: select a category and drag the
command out of this dialog box o a toolbar,

Categories: Commands:

Customn Menu Ttem d
@ Custamn Button

Selected cormand:

Description | IModify Selection =

o

NOTE: A macro button can also be added to a menu by dragging the icon to a menu.
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c. Click and drag the Custom Button icon (yellow happy face) to your toolbar. You will see
an I-beam on the toolbar to indicate the button’s placement.
M X M X
d. Make sure the button is highlighted, as shown above (it has the box around it). From the
Customize window, choose Modify Selection and then select Assign Macro..., Select
the macro you want for this button, and click OK. (Mac: CTRL+click on the button and
select Assign Macro...)
. J | K | L | M
Delete
Mame:  &Cuskom Button
Copy Button Image
Paste Butkon Image 211
Tookars  Command Reset Butkon Image
To add b Edit Button Image. .. h = =
command ouk of this di Change Button Image ? b LR _I_I
Cakegaries: Defalt Style + Macro name:
Data = ‘I , |Calculation % (o] 4
Wind_ow and Help Text Cnly (Alaays) I ----------------------------------------------------------------------------------------------------- I_I
EL?;\;TEapes Text Cnly (in Menus) Lcell
Charting
weh Image and Text = Edit
Fo?ms M. = —II
Control Toolbox LI P |
Assign Hyperlink 3

Built-in Menus

Selected command:

Assign Macro. .,

Description

Modify Selection ';

2

Close |

3. Change the Look of the Buttons

Macros in:

|
[

I.C\II Open Workbooks

Descripkion

' Macro recorded 3/23/2004 by Maureen Scoones
Calculates the MIN, MAX, AYERAGE, and SUM of range

a. To change the way the button looks (otherwise you will have all happy faces), click on
the Modify Selection button again. (Mac: double click on the button to open the
Command Properties window.) You can Change Button Image, or give the button
an appropriate Name and tell Excel to use Text Only (Always) or Image and Text.

b. Click on Close.

c. Move the new toolbar to suit your needs.

_ L F ] d Reset J [ K| L [ M & | F | g Resat J | kK ] L |
Delete Delete
Mame: &Custom Butbon | Mame: | Calculation| |
Copy Button Image Copy Button Image
Paste Button Image I | Paste Button Image 211
Toolbars  Command: Reset Button Image Toohars  Command Reset Button Image
Tt scmae) ] it (NN -
command out ol 15 i ange BUCton lmage L3 Ay command out ol 15 di ange Suctton Image
C;::ories: Default Style i g; Z} ? g g C;;::DriES: Default Style ﬁ
\[v)\:ig"c\llionv;and Help Text Only {Always) Gy VoA B\:igﬂion\';and Help Text Only (Always)
gﬁtaorg:apes Text Only (in Menus) ﬂ B W % 0‘90 éﬁtaora::apes Texk Only (in Menus)
Char g Irnage and Texk “r 1t i — e g Image and Text My Maci v x|
Farms Faorms
Control Toolbox EE]| ) om @ H . Control Toolbox j
Euilt-in Menus dezigpliperinh R R - I Euilt-in Menus gesiglbpstink
Selected command: Assign Macro.., Selected command: Assign Macro. ..
Description Modify Selection Description Modify Selection ]

e

Close |

)

Close |
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Reassigning a Shortcut Key
1. From the Tools menu, choose Macro and then Macros....
2. Select a macro from the list and then click on Options.

Macro name: Macra name:
|Calculation E=| Calculation
- I >Sh0rtcut key:
anee ceri+[X
Step Inta | Description:
Macro recorded 3/23/2004 by Maureen Scoones
Edit | Calculates the MIN, Max, AVERAGE, and SUM of range
ﬂl ok I Canicel
LI Delete |
IMacros in: IP.II Open Workbooks ( >| Optiares. .

Description

IMacro recorded 3/23(2004 by Maureen Scoones
Calculates the MIN, MA¥, AYERAGE, and SUM of range

3. In the Macro Options window, you can change the Shortcut key or change the Description.
4. Click on OK.

For questions or comments regarding this document, please e-mail docxteam@hamilton.edu.
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